Only renders on one eye with Multiview (Oculus Quest 2)

  • updated
  • Fixed

Shapes only renders in on eye when in Multiview for mobile VR (Oculus Quest 2).

Image 465

From reading a previous ticket, it seems that Single pass instanced works

Image 466

However it doesn't seem to be the case for Multiview...

I'm using Shapes 3.2.3. Is it supposed to work on that version?

(I didn't try version 4.0.2 because it didn't mention it'd fix the issue, and plus it says it has breaking change)

Thanks for helping!

Reporting a bug? please specify Unity version:
Reporting a bug? please specify Shapes version:
Reporting a bug? please specify Render Pipeline:
Gael Flores

I just found out it's not bugged with every shapes.

With Line and Polygon it works well on both eyes.
However it only renders on the left eye when it's a Disc or Polyline.

Strange isn't it?



I have the same problem.

Some shapes render correctly on both eyes, and some don't, in Single pass Instanced.

I tried multi pass for curiosity. Shapes' standard objects render correctly, but not the polyline drawn by script. (the curve in the middle. Colored little spheres are not from Shapes, they're just for bezier visualization)

I hope this can help.



Unity: 2020.2.1f1

Shapes: 4.0.2

Render Pipeline: HDRP

Target platform: XR on windows (oculus)

Stereo rendering mode: Single pass Instanced

Freya Holmér creator
  • Under Review

hm, this should have been fixed long ago, but it's possible this might've been caused by another issue I've fixed for 4.0.3. 

I'd say try it again in 4.0.3 once it's out!

another thing worth trying is a clean reinstall. sometimes strange issues like this are caused by upgrading in place

Gael Flores

Thanks for your message!

When will 4.0.3 be out?

Also there's still a chance the bug won't be resolved then?

If that's the case, then when will that bug be resolved?


Freya Holmér creator

I aim to release 4.0.3 hopefully today or tomorrow!

if it isn't fixed with 4.0.3 then there's no way for me to tell when it's done, because this is one of those situations where it should work, but it doesn't, and I don't know what could possibly be wrong :c We'd have to start searching and figuring out if this is even a thing on my end, or Unity's end, or HDRP specific, or platform specific, or VR specific, and so on. it would take a while most likely, and I can't promise anything I'm afraid

that said - do try the clean install I mentioned above in the meantime!

Gael Flores

Can't be happier, seems to be fixed in 4.1.0! Thanks!

Freya Holmér creator
  • Fixed

glad it worked out!

NewMagic Studio

How did you get single pass instanced? i used Unity 2020 and Unity 2021 and don't get single pass instanced, just multiview and multipass


I faced the same issue and after a lot of searches, I solved it. I created the following tutorial video: