Shapes not rendering on older (<=2016) iPads

  • updated
Recently, shapes has stopped rendering on older iPads (2016 and older), while still working correctly on iPads from 2017 and newer, editor, mac builds, etc.

I tried a full reinstall, including deleting the Library folder and setting "Instancing Variants" in "Shader Stripping" to "Keep All".

Reporting a bug? please specify Unity version:
Reporting a bug? please specify Shapes version:
Reporting a bug? please specify Render Pipeline:
Freya Holmér creator

this is likely something on Unity's end - there's no device compatibility code on my end I'm afraid! the biggest thing you have control over is whether or not to use GPU instancing, which may or may not be supported by your platform


Thanks for the reply.

We also tried disabling GPU instancing, and still have reports of the same problem.

We tried to move our project from Unity 2022.1 to latest version last week, 2022.2.16f1, with same results.

After more investigation, all reported failing devices are iPad Pro 2017 models (A1709 and A1701), with PowerVR Series 7 GPUs. We ordered one of these models so we can do more tests next week and try to find a work around.

Thanks for your support.