Old ShapesConfig script not removed on 3.0.0 install?

Avatar
  • updated
  • Unity's Fault

Using Unity 2020.2.4f; upgrade to 3.0.0 threw errors on compile due to existing ShapesConfig script from 2.3 - commenting out old ShapesConfig resolved compile errors. I guess it should have been removed on installing the 3.0.0 upgrade; Maybe something specific to my machine but wanted to let you know.

Thanks for the upgrade! Shapes has really improved the visuals of my prototype

Reporting a bug? please specify Unity version:
2020.2.4f
Reporting a bug? please specify Shapes version:
3.0.0
Reporting a bug? please specify Render Pipeline:
URP
Pinned replies
Avatar
Freya Holmér
  • Answer
  • Unity's Fault

sounds like a possible bug in how Unity handles upgrading assets, since it will work fine in fresh installs

I guess it's tricky for Unity to know what to replace and what to keep if a user has made changes to files that are included in an asset, not sure what the best way to handle this without lots of overhead work for me every time I want to rename/remove something

Avatar
Freya Holmér
  • Answer
  • Unity's Fault

sounds like a possible bug in how Unity handles upgrading assets, since it will work fine in fresh installs

I guess it's tricky for Unity to know what to replace and what to keep if a user has made changes to files that are included in an asset, not sure what the best way to handle this without lots of overhead work for me every time I want to rename/remove something

Avatar
Patrick
Quote from Freya Holmér

sounds like a possible bug in how Unity handles upgrading assets, since it will work fine in fresh installs

I guess it's tricky for Unity to know what to replace and what to keep if a user has made changes to files that are included in an asset, not sure what the best way to handle this without lots of overhead work for me every time I want to rename/remove something

Makes sense - Maybe no one else will even encounter it.

Best

Pat

Avatar
eddy

I have the same issue. After updating to 3.0.0 I have a tone of ShapesConfig related errors, everything is not happy with the class being static. If I comment or delete, other scripts are not happy...

I am sure it's not really your fault and, like you said, unity's way of managing assets is a mess.

Do you have a clue on how I can solve this ? (I am afraid about loosing what I made with shapes if I clean the package then do a fresh install).

Avatar
Freya Holmér

delete the old shapes config file (or all of Shapes) and reinstall/update. as long as your stuff was outside of Shapes folders then nothing should be lost

Avatar
eddy
Quote from Freya Holmér

delete the old shapes config file (or all of Shapes) and reinstall/update. as long as your stuff was outside of Shapes folders then nothing should be lost

Thanks a lot. That did it, and everything stayed the way it was.
Bonkers asset. Thanks for the very quick response and also your learning content on youtube is very helpful. I wish you the best!