Shapes are never culled even after changing bounds

Avatar
  • updated

I have a few menus/scenes that are made up of lots of shapes. They are placed at places like (0,500,500), very far away from the camera. The camera goes to them when they are active.

I have set the bounds of everything to be 50

As far as I am aware everything in these menus should be culled.

If I look at the frame debugger I can see that everything is still being drawn

Compared to when I disabled the menus:

So am I totally missing something?

Does unity just never cull in editor?

I thought I checked this a while ago and it WAS working properly, maybe I broke something?

I plan to disable all these objects anyways, but I just to make sure I understand whats going on.

Reporting a bug? please specify Unity version:
2020.3.7
Reporting a bug? please specify Shapes version:
3.2.3
Reporting a bug? please specify Render Pipeline:
HDRP
Avatar
Alan Sherba

So I just realized there is a proper settings menu with a button I need to press LOL

Before I was directly editing the scriptable object

Once i pressed Apply everything worked how I expected.

Maybe put a warning on the scriptable object?

Avatar
Freya Holmér

I do have a warning on the Shapes Import State but I guess I should add it to the others too!

Avatar
Freya Holmér

this has now been fixed in 4.1.0