LinearBurn, ColorBurn, ColorDodge Blend Modes show up in Scene View, but not in game

Avatar
  • updated

Hi there,

I'm noticing that certain blend modes do not render in the game view or in a build (I'm on Windows 10), but they show up in the scene view. The blend modes are LinearBurn, ColorBurn and ColorDodge. 

(Other blend modes show up fine in both views)

In the following example, the left disc has linear burn, the right disc has LinearDodge (Additive).

Thanks!

Reporting a bug? please specify Unity version:
2019.4.26f1
Reporting a bug? please specify Shapes version:
4.1.0
Reporting a bug? please specify Render Pipeline:
Built-in render pipeline
Avatar
Freya Holmér

does enabling/disabling HDR in the camera make a difference?

Avatar
SharkWithLasers

By default, I had the camera on "Use Graphics Settings".

When I turned it off, the scene view stopped working (at least for linear burn):

However, it shows up when I turned it back to "Use Graphics Settings", and made sure to check "Use HDR" in the Graphics tab:


Avatar
Freya Holmér

I think this is simply a limitation when color buffers don't support negative values :c
I don't think it's anything I can fix, though I should clarify that these blend modes have limitations