Different documentation per version

Avatar
  • updated
  • Declined

Hi,

I am using Shapes for a while now and because I am pretty lazy updating (especially because I tweaked the shaders for my very special use case) I use quite an old version of Shapes. However, not only the package is evolving but also the documentation and I am more and more confused because of the divergence between documentation version and my plugin version.

So maybe it would be cool to have a version selector for the documentation? Just in the same way the Unity Manual has an Engine version selector at its top left corner! Or would this require too much effort for the benefit it would generate?

Thanks for the great work!

Reporting a bug? please specify Unity version:
2019.4
Reporting a bug? please specify Shapes version:
2.3.2
Reporting a bug? please specify Render Pipeline:
Other
Pinned replies
Avatar
Freya Holmér
  • Answer
  • Declined

I think this would unfortunately be too much effort and overhead on my end. I do recommend upgrading though, there has been some big improvements and changes especially since 4.0.0, and I've made sure to add warnings and errors that tell you what has been deprecated and how to update it :)

Avatar
Freya Holmér
  • Answer
  • Declined

I think this would unfortunately be too much effort and overhead on my end. I do recommend upgrading though, there has been some big improvements and changes especially since 4.0.0, and I've made sure to add warnings and errors that tell you what has been deprecated and how to update it :)

Avatar
timbrando

Well, okay. :D

Thanks for your fast answer!

Maybe I will update and then save the current version of the documentation for future reference. ]:)