[XR] [URP] MSAA Not Working When Shapes is in Project

Avatar
  • updated
  • Unity's Fault

MSAA works before Shapes is added to the project. After importing and building MSAA is now disabled.

No shape components exist and draw calls have been done yet.


I saw that a render feature was added but disabling it doesn't allow the MSAA setting set in the Render Asset to work again.

Not sure if Shapes is adjusting the render pipeline in some way or overriding MSAA for it's own AA solution?

Reporting a bug? please specify Unity version:
2020.1.17
Reporting a bug? please specify Shapes version:
3.1.1
Reporting a bug? please specify Render Pipeline:
URP
Pinned replies
Avatar
Freya Holmér
  • Answer
  • Unity's Fault

Shapes doesn't do anything to modify any MSAA settings in your project, so this looks like it might be a URP bug :c

one thing you can try is directly getting/setting PipelineAsset.msaaSampleCount to see if it's correctly configured

Avatar
Freya Holmér
  • Answer
  • Unity's Fault

Shapes doesn't do anything to modify any MSAA settings in your project, so this looks like it might be a URP bug :c

one thing you can try is directly getting/setting PipelineAsset.msaaSampleCount to see if it's correctly configured

Avatar
Raincoat

Must be some setting issue that gets triggered when Shapes is imported then.

I tested in an empty project and MSAA worked fine.


However performance dropped significantly in build. No lines were being drawn still.

Out of curiosity I switched to Vulkan and performance was normal again?

Not sure of that’s just URP or not.